Forums

Post Reply
Forum Home > Iridium Server Manager Help > Java Problem

kacper19990
Member
Posts: 1

While trying to start the server I get this error:

 

 

 

Server Started at: 2013-07-22 16:27:22

 

Usage: java [-options] class [args...]

 

(to execute a class)

 

or java [-options] -jar jarfile [args...]

 

(to execute a jar file)

 

where options include:

 

-d32 use a 32-bit data model if available

 

-d64 use a 64-bit data model if available

 

-server to select the "server" VM

 

-hotspot is a synonym for the "server" VM [deprecated]

 

The default VM is server.

 

-cp

 

-classpath

 

A ; separated list of directories, JAR archives,

 

and ZIP archives to search for class files.

 

-D

 

set a system property

 

-verbose:[class|gc|jni]

 

enable verbose output

 

-version print product version and exit

 

-version:

 

require the specified version to run

 

-showversion print product version and continue

 

-jre-restrict-search | -no-jre-restrict-search

 

include/exclude user private JREs in the version search

 

-? -help print this help message

 

-X print help on non-standard options

 

-ea[:

 

-enableassertions[:

 

enable assertions with specified granularity

 

-da[:

 

-disableassertions[:

 

disable assertions with specified granularity

 

-esa | -enablesystemassertions

 

enable system assertions

 

-dsa | -disablesystemassertions

 

disable system assertions

 

-agentlib:

 

load native agent library

 

see also, -agentlib:jdwp=help and -agentlib:hprof=help

 

-agentpath:

 

load native agent library by full pathname

 

-javaagent:

 

load Java programming language agent, see java.lang.instrument

 

-splash:

 

show splash screen with specified image

 

See http://www.oracle.com/technetwork/java/javase/documentation/index.html for more details.

 

Error: -jar requires jar file specification

--
July 22, 2013 at 11:33 AM Flag Quote & Reply

Roos-Skywalker
Member
Posts: 5

When you want to change the given ram, instead of checking ''Auto Detect'' you should uncheck it and direct it to your 64 bits Java. If you don't have it already: https://www.java.com/en/download/manual.jsp" target="_blank" rel="nofollow">Here When installed follow this path: C:\Program Files\Java\jre7\bin\javaw.exe click on javaw.exe not on any other Java! Now you assigned the right version of Java that supports more than 1GB ram.

--

March 4, 2014 at 11:10 AM Flag Quote & Reply

ImminentFate
Site Owner
Posts: 51

Your issue is that you have not specified a file name for the craftbukkit.jar file in the server parameters. 
Try entering a name (craftbukkit.jar) in the required field and it should work

March 8, 2014 at 1:04 AM Flag Quote & Reply

You must login to post.